JRANGER

Registered
  • Content count

    508
  • Joined

  • Last visited

Everything posted by JRANGER

  1. 65 Coupe to Fastback "Phoenix"

    hehe im currently chopping on the 69...Drivers floor was toast....I also picked up a 53...F-250....Sitting on an 01 Crown Vic P71 4.6L V8.........That also needs some rust repair and well redneck engineering fixes. I actually drove it home, with out a driver side window in 30 degree weather Saturday morning.....Needless to say i was cold
  2. Going to be converting a 65 coupe to a fastback. Got it yesterday and started gutting it. Interior removed, qtr windows removed, gas tank removed, taillights and qtr extensions off. Not a lot of rust, underside looks pretty good. Front pans will need some work and the trunk has a few holes but nothing crazy. Really solid car
  3. 65 Coupe to Fastback "Phoenix"

    Well. Since i have 2 Fastback now...I Put the 68 up for sale. It now belongs to a guy named Lucas in the BORO
  4. 65 Coupe to Fastback "Phoenix"

    The 69: Ive installed a 70s Shaker hood from KY Mustang, A shaker Setup, New Hood Trim, LED Headlights, and led light bulbs indie. Before pulling the interior out I wanted to start building a center console with fiberglass bottom and 3d printed inner portion. This way, I can test with the carpet in it and get the fitment pretty well down. Now with the carpet out, I fine what I expect, tin and rivets!!! UGH!!!! Luckily it seems to only be the drivers side pan so it wont be too hard to replace. The 68: Its pretty much all together minus a few pieces of rubber. Yesterday i was troubleshooting electrical issues as my turn signals wouldn't work while the car was running. Think I had a bad ground as the LED flasher module wouldn't completely tighten, plus the 1 wire alt was wired up with a 12awg wire so I swapped that for a 4awg wire. I also ran it out of fuel, so i emptied about 1 gal out which apparently is the Empty point where the car wont run. Either way, I finally installed a new sending unit (Took 2 attempts for proper seal) and put 3 gals of gas in her. She is running and the gauge is finally getting some reading....Pretty sure this has a 22 gal tank in it but the old sender was trash...A brand new tank with a rusty sender minus the filter......POS people....I also put her up for sale on FB as i really don't need to have 3 Mustangs lol......
  5. The old Goat

    Thats just awesome
  6. 65 Coupe to Fastback "Phoenix"

    So been busy and still haven't got back to work on the 65. I did just paint my 68 and also bought a 69
  7. 65 Coupe to Fastback "Phoenix"

    doesnt even matter now. Sold the 73 today
  8. 65 Coupe to Fastback "Phoenix"

    So today I took the 73 out for about a 20 min drive down to MT Pleasant. My buddy and I took off all the brackets and replaced the water pump. Left all the AC brackets off...I'm done with crap that doesnt work and gets in the way. On the drive home apparently we didnt have the top hose connected tight enough because it blew off and after all that the battery was weak. So a jump start and some water got me home. Ordered a 1wire 100amp alt, new belts, and will flush the radiator out and put new coolant in.
  9. 65 Coupe to Fastback "Phoenix"

    Went to the All Mustang and Ford car show in Mt Juliet today. Man there were some nice stangs out there....I actually drove a 67 galaxie out there for my buddy while he drove his 67 Shelby GT 350 clone. Fun times.....Lots of cool fords
  10. 65 Coupe to Fastback "Phoenix"

    I feel better about it after yesterday. A friend came over yesterday and really thought it was probably the overflow getting into the fan. So ive ordered an overflow tank so i can at-least eliminate that. Also need to replace the water pump line but that is tough to get too stupid AC system. I may just try to remove all the AC stuff anyway. That way i get it out of the way
  11. 65 Coupe to Fastback "Phoenix"

    I hate thie MF!!!##$#(@_(J#RO{OFSMF:ADO 73 Mustang.....Did an oil change and took her for a drive. Got it warm and slammed the petal up to 60mph and started to see smoke. Turns out i have another coolant leak. I just cant win with this damn car
  12. ITSnolongerASIX 1966 Mustang

    not sure how it compares to the mirror setup but ive always painted the inside of light fixtures white to enhance the lighting.good work though
  13. 65 Coupe to Fastback "Phoenix"

    ITS back up and running properly. New Plugs, New PCV, New Vacuum lines, Valve covers, and now she doesnt stall out when put in gear. Still have to loosen the bolt on the transmission linkage. The leak is still gone but its not quiet going into gear right because it go over tightened. Actually popped back into neutral a couple times while i was driving
  14. 65 Coupe to Fastback "Phoenix"

    As always, 1 step forward 2 steps back.. New radiator is in. Car isnt idling well and stalls when put in gear. I'm assuming I either have a vacuum leak or ignition issue. Especially given my last experience with points. Next steps: Replace leaky valve covers Replace Spark Plugs Install Petronix replace pcv and vacuum advance hoses
  15. 65 Coupe to Fastback "Phoenix"

    Well I didnt go rent a pressure tester instead I just blew air into the radiator through the overflow. Instantly coolant started shooting out the passenger side of the radiator. It's by the hose but its not coming from the hose. Its sprays like a mist right out of the top row. Time to order a new radiator
  16. 65 Coupe to Fastback "Phoenix"

    Well today I took it for another test drive with a new radiator cap. I also tightened to the bolt where the o-ring is and the leak has stopped or got way smaller1. I apparently tightened the kickdown/o-ring area too much. As the shifter is a struggle to put into gear.2. SAME issue. After warming up it blows coolant all over and no real idea where from. It appears to be around the passenger side but it doesnt look like it's from the main hose. I'm getting to wonder if the radiator has a hole some where and considering trying some stop leak3. Also when it gets warm it also starts having the oil light come on when idle so blah. This could also be due to the coolant possibly maybe getting on the sensor
  17. 65 Coupe to Fastback "Phoenix"

    Today is pissing me off. I replaced a o ring on the trans...still leaks blah!! I took.it for a drive and was all happy until I got home and coolant was everywhere. On the hood, baggery, radiator, wtf Top it off and i need to replace.my main breaker at home. It's been getting weird and the mfer is stuck and wont come tf out. Stupid pos murray mdh junk mfer
  18. 65 Coupe to Fastback "Phoenix"

    Still remodeling the kitchen. Pulled the 73 out and ran her down the road. Then installed the rear valance and bumper. Still needs adjustment Also yeah, had Joey help me and pulled this out of a pasture in ShelbyVille TN yesterday
  19. 65 Coupe to Fastback "Phoenix"

    ive been in kitchen remodel hell for over a month and haven't done anything Well after a whole lot of sanding and work in the kitchen, i cut a few stump down past level ground for my parking area. Decided i was pulling the 73 out to try to turn it around. First thing was it wasn't going into gear and i knew it had been leaking trans fluid. So i put 3 qts in and it shifts into gear no problem. So i pull it out and know i cant make the turn so i pull it down the driveway to back it in to the parking area. Quickly i find out its not POSI as one wheel hits the dirt and just starts spinning. I pull it forward a cross the whole driveway only for it to stall. Keeps stalling and i think maybe i ran it out of gas so i put some more in it. Keeps stalling. Keeps spinning the tires but eventually while holding the gas and burning tires in the dirt i get it backed into the garage. SO i start trying to start it and it continues to stall out. Turns out the hose came off the pcv...UGH!!! lol
  20. 65 Coupe to Fastback "Phoenix"

    ITS ALIVE!!! I installed an electric fuel pump i got from Matt that is way too aggressive but it cleared my lines out. I have a hidden switch for it in my console so i can turn it on and off. After using it you can see a noticeable amount of junk in the fuel filter and the mechanical pump is now working. Its smokes like crazy but i pretty sure i poured seafoam in the gas tank. It also needs an oil change badly! So ill do that and then i can hopefully get it tuned
  21. 65 Coupe to Fastback "Phoenix"

    Well ive been waiting on AN fittings so i can put an electric fuel pump on the 73 and squirreled a little further. I did get the table saw up and running. Built a TV stand in 2 days from pallet wood and fencing but its not quiet done...To match the bar i built 3 years ago i'm going to have to sand it all the way down to raw wood. Then hit it with poly. The table saw came in handy. My AN fittings have finally showed up so hopefully i will at least have the 73 running. However i'm about to start on a kitchen remodel.....I'm never going not finish these cars