mstrpth

2014 explorer ecoboost code P0016

30 posts in this topic

lol  How about Tannerite'd at Ashley Ps?

Ford recommends "pinpoint test HK".  If you can't find it on google, I can get if for you.

Share this post


Link to post
Share on other sites
19 minutes ago, Ashley P said:

lol  How about Tannerite'd at Ashley Ps?

Ford recommends "pinpoint test HK".  If you can't find it on google, I can get if for you.

I moved into my new house late this summer. I've already had the cops show up twice for tannerite. :D 

I'll look it up. Thanks!

Ashley P likes this

Share this post


Link to post
Share on other sites
On 2/3/2020 at 7:12 AM, mstrpth said:

I've got some major house projects coming up..

Hey, I'm interested in the house.  I can use all kinds of ideas.  Lately my best idea is to pick Chevy driving carpenters to trade house/truck work.  My old house is keeping them as busy as their worn out Chevys are keepin' me. lol

66sprint6 likes this

Share this post


Link to post
Share on other sites

explorer finally started showing signs. Bad surge at idle. Give it min amount of pedal and it stops. Took it to the ford dealer as I have zero free time and this is the verdict.

Any of this look wrong?

SmartSelect_20200611-070053_Gallery.jpg

Share this post


Link to post
Share on other sites

The code didn't follow the sensor, and sounded mechanical in nature.  Looks like a typical cover all bases repair.

The "wrong" thing:  having to spend $3300+ to repair the complexities that are on the engine to give it 15% better mileage.   Cost/benefit ratio analysis = failure.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.