Rate this topic:

809 posts in this topic

I'm far from famous lol just busy with life. Redoing everything on the car and have a kid on the way, and started a new job about a month ago. 

 

Car ran 8.78 at 155 on 19 lbs with the s485. Didn't want to make any more boost because of back pressure. (That's with a converter to tight, dropping from 7200 to 5500 during the shift) so I decided I was going to put a fi s488/100 on it with the 1.45 ar tial v band housing. Got the housing and got an amazing deal on a fi gt55 with 1 pass in it. About 1000 less than what a new one cost (was pretty much new). So I bought that and it's gone crazy since. Going all 2.5 stainless with manifold headers and a 5 inch down pipe. Also changed the floor and driveshaft. I had a u joint explode on the dyno. So out goes the 3 inch chromoly with 1310s and came in a 4 inch aluminum with 1350s u joints everywhere. Had to cut the floor up and redo the tunnel for it to fit. Got a digital dash that fit in the stock location. The rear suspension is a lot safer and stronger now. Went with sliders with crossmembers to stiffen everything up. 

FB_IMG_1548124883417.jpg

20190123_171458.jpg

Tino and Ashley P like this

Share this post


Link to post
Share on other sites

Dude, good to hear from ya!   Neat (as usual) car.   Kid on the way...CONGRATS!   Nothing slows a car down like PRIORITIES.....here's to hopin' you keep them in order. ;) 

Ya gotta vid of that beast?  If you give us a wheelie vid we'll leave you alone for another year... :) 

Share this post


Link to post
Share on other sites

I got a new phone in December so I dont have anything on this phone. Let me see if I can get them off it. I did a bad wheelie and almost hit the wall. Changes shocks in all 4 corners and no more wheelies lol also bought a new house in may. It's been a busy year.

 

As for the kid I am trying to get the car race ready and be done doing stuff to it for a long time. It's a girl 

6898.jpeg

JohnC likes this

Share this post


Link to post
Share on other sites

^ Hey, we've seen that old pic, your not off the hook yet.  :D

How's the house/property?  Maybe you were about to sign for it last I heard...

Share this post


Link to post
Share on other sites

Well not much has happened. Car is slowly getting worked and I'm hating my new set up. I regret changing at all.

Sent from my SM-G950U using Tapatalk

JohnC likes this

Share this post


Link to post
Share on other sites
6 hours ago, Cody said:

Well none of my pictures loaded....

Use Tapatalk picture upload...

Might allow full size. 

I need to update this forum soon.....

Share this post


Link to post
Share on other sites
Use Tapatalk picture upload...

Might allow full size. 

I need to update this forum soon.....

It will only let me load one at a time

Sent from my SM-G950U using Tapatalk

Share this post


Link to post
Share on other sites
Bet it'll stop much better now. :yes: 

Was it scary stopping with the old shoe brakes? :fear: 

It really was because one didn't work well lol

Sent from my SM-G950U using Tapatalk

JohnC likes this

Share this post


Link to post
Share on other sites

Had the car on the dyno last weekend. Have some fuel issues which I think is electrical. With e85, base pressure of 43, magnafuel 4303 with an aem 380 to help, real bosch 210s I was at 75% injector duty. I think there is some noise of something somewhere. The pump was rebuilt by magnafuel this winter and I have brand new 210s. Car made just over 800 on a 10 psi spring though. This gt55 is letting it breathe now. 13dfc87a7ae271c647126212699fff92.jpg633659beaf3b48a9d210e9e48663f5ca.jpg

Sent from my SM-G950U using Tapatalk

Tino and Ashley P like this

Share this post


Link to post
Share on other sites

Dyno-schmyno.   Put me and a clutch pedal in that thing at the track and I'll tell you how much power it makes!  lol  (It would quickly peg my butt dyno.)

Share this post


Link to post
Share on other sites
Dyno-schmyno.   Put me and a clutch pedal in that thing at the track and I'll tell you how much power it makes!  lol  (It would quickly peg my butt dyno.)

Glad I went to the dyno first. I had a regulator mess up my computer was adding 50% more fuel and was still lean.

Sent from my SM-G950U using Tapatalk

Share this post


Link to post
Share on other sites
figure out the injector issue?

I'm not sure yet. Haven't had a lot of time to mess with it. I'm hoping so but who knows.

Sent from my SM-G950U using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.